Installing Ant plugin in Aptana Studio

Because Aptana is build for Web development it don't have Ant in its bundle (as it comes with Eclipse). We need to install JDT with some simple steps to run Ant in Aptana


1) Go to; Help >> Install New Software
2) In the next window click on this entry: Eclipse Galileo Repository - http://download.eclipse.org/releases/galileo
3) Select the Programming Languages >> Eclipse Java Development Tools
4) Next and Finish

After finishing installation, you can check Ant @ Window>> Show View>> Other

If you still unable to install, feel free to comment.

7 comments:

  1. Hey, just found your Post here.. Aptana (Aptana Studio 3, build: 3.0.9.201202141038) tells me it has a conflicting dependency:

    Cannot complete the install because of a conflicting dependency.
    Software being installed: Eclipse Java Development Tools 3.5.2.r352_v20100108-7r88FEwFI0WTuoBl0iaG0tyhfZH6 (org.eclipse.jdt.feature.group 3.5.2.r352_v20100108-7r88FEwFI0WTuoBl0iaG0tyhfZH6)
    Software currently installed: Aptana Studio 3 3.0.9.201202141038-14022012104032 (com.aptana.rcp.product 3.0.9.201202141038-14022012104032)
    Only one of the following can be installed at once:
    Simple Configurator Manipulator 1.0.101.R35x_v20100209 (org.eclipse.equinox.simpleconfigurator.manipulator 1.0.101.R35x_v20100209)
    Simple Configurator Manipulator 2.0.0.v20100503 (org.eclipse.equinox.simpleconfigurator.manipulator 2.0.0.v20100503)
    Simple Configurator Manipulator 1.0.100.v20090520-1905 (org.eclipse.equinox.simpleconfigurator.manipulator 1.0.100.v20090520-1905)
    Cannot satisfy dependency:
    From: Aptana Studio 3 3.0.9.201202141038-14022012104032 (com.aptana.rcp.product 3.0.9.201202141038-14022012104032)
    To: org.eclipse.equinox.simpleconfigurator.manipulator [2.0.0.v20100503]
    Cannot satisfy dependency:
    From: Eclipse Java Development Tools 3.5.2.r352_v20100108-7r88FEwFI0WTuoBl0iaG0tyhfZH6 (org.eclipse.jdt.feature.group 3.5.2.r352_v20100108-7r88FEwFI0WTuoBl0iaG0tyhfZH6)
    To: org.eclipse.jdt.junit [3.5.2.r352_v20100113-0800]
    Cannot satisfy dependency:
    From: Java Development Tools JUnit support 3.5.2.r352_v20100113-0800 (org.eclipse.jdt.junit 3.5.2.r352_v20100113-0800)
    To: bundle org.eclipse.equinox.simpleconfigurator.manipulator [1.0.100,2.0.0)


    Any ideas?
    Patric

    ReplyDelete
  2. Hi Gaurav, This article is very useful but now i have a problem. I have being developed phonegap application for iOS that is used pre populated .db file. This solution is working fine for below iOS 5.1. But I upgraded to IOS 5.1 , this solution does not to work.
    Can you give me a solution for that. I am stuck now.
    Thank you

    ReplyDelete
  3. I too get a conflicting dependency with Aptana 3 + juno (http://download.eclipse.org/releases/juno)

    ReplyDelete
  4. The solution for Aptana 3 is to use helios: http://download.eclipse.org/releases/helios

    ReplyDelete